DRGB stopped working on 3070 Waterblock


New member
I purchased the https://www.alphacool.com/shop/gpu-...acryl-gpx-n-rtx-3070-rog-strix-with-backplate waterblock for my 3070 about 4 months ago. My mobo at the time (ROG Maximus IX Hero) didn't have any drgb connectors so I purchased the Alphacool argb controller and the RGB on the waterblock worked fine. A few days ago I upgraded my mobo and CPU. My new mobo (Aorus Master X570S) does have DRGB connectors, so I plugged in the GPU water block and my new CPU water block (https://www.ekwb.com/shop/ek-quantum-velocity-d-rgb-amd-nickel-plexi) into the two DRGB connectors on my new mobo. The CPU waterblock RGB worked fine, but the GPU one never came on. I decided to do some tests so I plugged the GPU block's DRGB cable into the other connector (where the CPU was) and it still didn't work. I also tried plugging it into the Alphacool ARGB controller, which I used previously and the RGB didn't come on as well. What could have happened that the RGB on the watterblock stopped working completely? What can I do to fix it?


... the nice marketing guy next door
Staff member
Hi & thanks for the info. Please write an email to our support (info@alphacool.com) and link to this thread. You will quickly get feedback on how to proceed.